hdu 2084 数塔

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2084

分析:比较典型的动态规划问题,自底向上,递推公式:dp[i][j] = max(dp[i+1][j], dp[i+1][j+1]) + map[i][j] ,最后的根元素就是最大值。

/*数塔



Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 25363    Accepted Submission(s): 15285





Problem Description

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:



有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?



已经告诉你了,这是个DP的题目,你能AC吗?

 



Input

输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

 



Output

对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

 



Sample Input

1

5

7

3 8

8 1 0 

2 7 4 4

4 5 2 6 5

 



Sample Output

30

 



Source

2006/1/15 ACM程序设计期末考试

 

*/

//Talk is cheap, show me the code

//dp[i][j] = max(dp[i+1][j], dp[i+1][j+1]) + map[i][j]

#include <cstdio>

#include <cstring>

#include <iostream>

#include <algorithm>

using namespace std;

const int maxn = 100 + 10;

int map[maxn][maxn], dp[maxn][maxn];

int main()

{

    int c, n;

    scanf("%d", &c);

    while(c--){

        scanf("%d", &n);

        memset(map, 0, sizeof(map));

        memset(dp, 0, sizeof(dp));

        for(int i = 0; i < n; i++)

            for(int j = 0; j <= i; j++)

                scanf("%d", map[i]+j);

        

        for(int i = n-1; i >= 0; i--)

            for(int j = 0; j <= i; j++){

                dp[i][j] = max(dp[i+1][j], dp[i+1][j+1])+map[i][j];

            //    printf("%d\n", dp[i][j]);

            }

                

        printf("%d\n", dp[0][0]);        

        

    }

    return 0;

}

 

你可能感兴趣的:(HDU)