POJ 2001 Trie

给出的单词不会重复出现,可以建立字典树,设一个域为当前结点重复次数(或者是否重复),对每个单词输出到第一个不重复的字母或者这个单词的结尾。

-----------------------------------------------------------------------------------------

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate

cart

carburetor

caramel

caribou

carbonic

cartilage

carbon

carriage

carton

car

carbonate

Sample Output

carbohydrate carboh

cart cart

carburetor carbu

caramel cara

caribou cari

carbonic carboni

cartilage carti

carbon carbon

carriage carr

carton carto

car car

carbonate carbona
-------------------------------------------------------------------------------------------------
# include <stdio.h>



struct tree{

    tree *node[26];

    int cnt;

    tree() {

        cnt = 0;

        for (int i = 0; i < 26; ++i)

            node[i] = NULL;

    }

} *root;



char str[1005][25];



void visit(tree *p, char *s, int bj)

{

    char c = (*s) - 'a';

    

    if (p->node[c])

    {

        p = p->node[c];

        if (!bj) {putchar(*s); if (p->cnt == 0) return ;}

        else ++(p->cnt);

    }

    

    else if (bj)

    {

        p->node[c] = new tree;

        p = p->node[c];

    }

    if (s[1]) visit(p, s+1, bj);

}



void release(tree *p)

{

    for (int i = 0; i < 26; ++i)

        if (p->node[i]) release(p->node[i]);

       delete p;

}



int main()

{

    int n;

        

    root = new tree;

    n = 0;

    while (~scanf("%s", str[++n]))

    {

        visit(root, str[n], 1);        

    }

    for (int i = 1; i < n; ++i)

    {

        printf("%s ", str[i]);

        visit(root, str[i], 0);

        putchar('\n');

    }

    release(root);

    

    return 0;

}

----------------------------------------------------------------------------------

你可能感兴趣的:(trie)