1962-Fibonacci

描述

 

This is an easy problem.I think Fibonacci sequence is familiar to you.Now there is another one.

Here a and b are constants.Gice you a,b,and n,your task is to calculate the f[n].

 

输入

First line of input comes a positive integer T(T<=10) indicating the number of test cases.Each test case contains three positive integer a,b and n(a<=10,b<=10,n<=30)

输出

Print one line containing an integer,i.e.f[n],for each test case.

样例输入

2

1 2 3

1 3 6

样例输出

3

24

#include<iostream>

using namespace std;



int main()

{

    int m,a,b,n,t;

    int sum=0;

    cin>>m;

    while(m--)

    {

        cin>>a>>b>>n;

        if(n==1) cout<<a<<endl;

        else if(n==2) cout<<b<<endl;

        else{

        for(int i=3;i<=n;i++)

        {

            if(i%2==1) t=a+b;            

            else

            {

                t=a+a+b+b;

                a=b+a;

                b=t;

            }

        }

        cout<<t<<endl;

        }

    }

    return 0;

}

  

你可能感兴趣的:(fibonacci)