A C[HDU1570]

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3107    Accepted Submission(s): 2008

 

Problem Description
Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

 

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

A C[HDU1570]
Now I will give you n and m , and your task is to calculate the answer .
 

 

Input
In the first line , there is a integer T indicates the number of test cases.
Then T cases follows in the T lines.
Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)
 

 

Output
For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).
And print the answer in a single line.
 

 

Sample Input
2
A 10 10
C 4 2
 

 

Sample Output
3628800
6
 

 

Author
linle
 

 

Source
HDU 2007-1 Programming Contest
 

 

Recommend
linle

#include<stdio.h>

int frac[11]={1,1,2,6,24,120,720,5040,40320,362880,3628800};

int main()

{

	int n,m,T;

	char ch;

	scanf("%d",&T);ch=getchar();

	while (T--)

	{

		scanf("%c%d%d",&ch,&n,&m);

		if (ch=='A') printf("%d\n",frac[n]/frac[n-m]);

		else printf("%d\n",frac[n]/frac[m]/frac[n-m]);

		ch=getchar();

	}

	return 0;

}

 

你可能感兴趣的:(HDU)