poj 2001 Shortest Prefixes

trie树

题意:
寻找到最短能区分出每个字符串的前缀

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11976 Accepted: 5099

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

Rocky Mountain 2004

[Submit]   [Go Back]   [Status]   [Discuss]

#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#define maxn 1005
#define maxl 22

class node
{
public:
	int times;
	node* np[26];
	node()
	{
		times = 0;/*当前点被访问次数*/
		for (int i = 0; i < 26; ++i)
			np[i] = NULL;
	}
};

node *root = new node;
node * cur = NULL, *new_node = NULL;

int str_num = 0;/*字符串数*/
char str[maxn][maxl];

void insert_str(char* a)/*插入一个字符串*/
{
	int len = strlen(a);
	int i = 0;

	cur = root;

	while (i < len)
	{
		char ch_tmp = a[i];
		int delta = ch_tmp - 'a';
		node* np_tmp = cur -> np[delta];/*对应字母对应的儿子指针*/
		if (np_tmp != NULL)
		{
			cur = np_tmp;
			++(cur -> times);/*儿子的次数加1*/
		}
		else/*新建结点*/
		{
			new_node = new node;
			++(new_node -> times);
			cur -> np[delta] = new_node;
			cur = new_node;
		}
		++i;
	}
}

void find_pre(char * a)/*查找最短前缀*/
{
	int len = strlen(a);
	int i = 0;
	cur = root;
	while (i < len)
	{
		char ch_tmp = a[i];
		int delta = ch_tmp - 'a';
		cur = cur -> np[delta];
		if (cur -> times == 1)
		{
			printf("%s ", a);
			a[i + 1] = '\0';
			printf("%s\n", a);
			return;
		}
		++i;
	}
	printf("%s %s\n", a, a);
	return;
}

int main()
{
	while (scanf("%s", str[str_num]) != EOF)
	{
		insert_str(str[str_num]);
		++str_num;
	}
	for (int i = 0; i < str_num; ++i)
	{
		find_pre(str[i]);
	}
	return 0;
}




你可能感兴趣的:(poj)