poj 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10556 Accepted: 5126

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu

[Submit]   [Go Back]   [Status]   [Discuss]

/*=============================================================================
#     FileName: 2752.cpp
#         Desc: poj 2752
#       Author: zhuting
#        Email: [email protected]
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-21 15:51:46
#   LastChange: 2013-12-21 15:51:46
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>

#define maxn 400005

char str[maxn];
int ans[maxn] = {0};

int* get(char * a)
{
	int len = strlen(a);
	if (len <= 0) 
		return NULL;
	int j = 0, k = -1;
	int * n = new int[len + 1];

	n[0] = -1;/*一开始漏了这个*/
	while(j < len)/**/
	{
		while (k >= 0 && str[k] != str[j])
		{
			k = n[k];
		}
		++j;
		++k;
		n[j] = k;
	}
	return n;
}

int main()
{
	while(scanf("%s", str) != EOF)
	{
		int ans_num = 0;
		int len = strlen(str);
		
		ans[ans_num++] = len;
		//printf("%d", len);
		int* tmp = get(str);
		int cur = len - 1;
		int next = tmp[cur + 1] - 1;
		while(true)
		{
			if (str[cur] != str[next])
				break;
			ans[ans_num++] = next + 1;
			//printf(" %d", next + 1);
			cur = next;
			next = tmp[cur + 1] - 1;
		}
		//printf("\n");
		for (int i = ans_num - 1; i >= 0; --i)/*要从小到大*/
			printf("%d ", ans[i]);
		printf("\n");
	}
	return 0;
}




你可能感兴趣的:(poj)