hdu1108 最小公倍数

倒计时第2天!——携程编程大赛,你报名了吗?

最小公倍数

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31067    Accepted Submission(s): 17286


Problem Description
给定两个正整数,计算这两个数的最小公倍数。
 

Input
输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.
 

Output
对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。
 

Sample Input
      
       
       
       
       
10 14
 

Sample Output
      
       
       
       
       
70
 

水题,纯粹是因为抓头发抓的难受学不进去做的- -

//============================================================================
// Name        : Math_hdu1108.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
using namespace std;

int main() {
	int i, j;
	int temp;
	while(cin >> i >> j){
		if(j > i)
			swap(i, j);
		if(i % j == 0){
			cout << i << endl;
			continue;
		}
		else{
			temp = i * j;
			while(i % j != 0){
				i = i % j;
				if(i < j)
					swap(i , j);
			}
			cout << temp / j << endl;
		}
	}
}


你可能感兴趣的:(hdu1108 最小公倍数)