sicily 1002 Anti-prime Sequences

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output No anti-prime sequence exists.

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

分析:

本题的思路很直白,因为数据量并不是非常大,只是1000的范围,长度为10,那么和最大也只有10000以内,所以可以暴力搜索,对每一个节点都进行判断并且迭代搜索,明显是用DFS。注意先用筛法做个素数表辅助判断,直接进行素数判断太麻烦,会超时。这里看到别人的代码,说道DFS卡时,其实就是限制DFS的总搜索次数,模糊判断用来节省时间。当然这样答案并不准确,但是对于数据规模较小的时候,可以取一些极限值测试,本题4000次搜索就足够了。

代码:

// Problem#: 1002
// Submission#: 1792032
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<cstring>
using namespace std;

#define MAX 10000
#define N 1010

bool isPrime[MAX];
int prime[MAX];
bool visit[N];
int re[N];
int n,m,d,t,sum;
bool flag;

void primeList(){
    memset(isPrime,true,sizeof(isPrime));
    for(int i = 2;i <= MAX;++i){
        if(isPrime[i])  prime[++prime[0]] = i;
        for(int j = 1,k;j <= MAX && (k = i * prime[j]) <= MAX;++j)
        {
            isPrime[k] = false;
            if(i % prime[j] == 0)   break;
        }
    }
}

bool judge(int len){
    int sum;
    if(len <= 1)    return true;
    for(int i = 0;i < len;++i){
        sum = 0;
        if(i <= len - d){
            for(int j = i;j - i + 1<= d ;++j){
                sum += re[j];
                if(j-i+1 > 1 && isPrime[sum])   return false;
            }
        }else{
            for(int j = i;j < len;++j){
                sum += re[j];
                if(j-i+1 > 1 && isPrime[sum])   return false;
            }
        }
    }
    return true;
}
            
void dfs(int num){
    if(++t > 4000)  return;
    if(flag)    return;
    if(!judge(num)) return;
    if(num== m - n + 1){
        flag = 1;
        return;
    }
    for(int i = n;i <= m && !flag;++i){
        if(visit[i])    continue;
        re[num] = i;
        visit[i] = 1;
        dfs(num+1);
        visit[i] = 0;
    }
}

int main(){
    primeList();
    while(cin>>n>>m>>d && n && m && d){
        flag = false;
        t = 0;
        memset(visit,0,sizeof(visit));
        dfs(0);
        if(flag){
            cout << re[0];
            for( int i=1 ; i<m-n+1 ; ++i ) cout << "," << re[i];
            cout << endl;
        }else cout << "No anti-prime sequence exists." << endl;
    }
    return 0;
}

你可能感兴趣的:(数论,ACM,DFS,sicily,soj)