浮动静态路由
实验目的:
1. 使用浮动静态路由实现路由备份
2. 观察动态路由EIGRP与静态路由之间的转换
3. 浮动静态路由本身是静态路由,浮动是指当原来的路由失效才启用该路由,在配置静态路由时需要将其管理距离做相应的调整,使其大于正常使用的其他路由协议获悉的路由。
实验拓扑:
实验配置:
R1# show running-config
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial0/1
ip address 16.16.16.1 255.255.255.0
!
interface Ethernet1/1
ip address 192.168.0.1 255.255.255.0
half-duplex
router eigrp 1
network 1.1.1.0 0.0.0.255
network 16.16.16.0 0.0.0.255
no auto-summary(如果不关闭自动汇总,则EIGRP宣告汇总的1.0.0.0/8网络,此时在R6上配置的到1.1.1.0/24的静态路由,EIGRP认为这是2个不同的网络,R6上的静态路由将被认为是普通的静态路由而非浮动静态路由)
ip route 6.6.6.0 255.255.255.0 192.168.0.2 200
R6#show running-config
interface Loopback0
ip address 6.6.6.6 255.255.255.0
interface Serial0/1
ip address 16.16.16.6 255.255.255.0
interface Ethernet1/1
ip address 192.168.0.2 255.255.255.0
half-duplex
!
router eigrp 1
network 6.0.0.0
network 16.16.16.0 0.0.0.255
no auto-summary
!
ip route 1.1.1.0 255.255.255.0 192.168.0.1 200
!
实验验证:
R1#sh ip route
Gateway of last resort is not set
16.0.0.0/24 is subnetted, 1 subnets
C 16.16.16.0 is directly connected, Serial0/1
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
6.0.0.0/24 is subnetted, 1 subnets
D 6.6.6.0 [90/2297856] via 16.16.16.6, 00:05:20, Serial0/1
C 192.168.0.0/24 is directly connected, Ethernet1/1
可见在R1的路由表上没有显示到6.6.6.0/24网络的静态路由,如果配置带送出借口的静态路由,路由器会认为该网络是直连的。
R6#sh ip route
16.0.0.0/24 is subnetted, 1 subnets
C 16.16.16.0 is directly connected, Serial0/1
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 16.16.16.1, 00:06:38, Serial0/1
6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback0
C 192.168.0.0/24 is directly connected, Ethernet1
在R1上:
R1#ping 6.6.6.6 repeat 1000 在R6上关闭s0/1接口在开启
R1#ping 6.6.6.6 repeat 1000
Sending 1000, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!.......!!!!!!!!!
Jul 20 19:56:49.019: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 16.16.16.6 (Serial0/1) is down: holding time expired!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Jul 20 19:56:58.971: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 16.16.16.6 (Serial0/1) is up: new adjacency!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!
Jul 20 19:57:03.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down
Jul 20 19:57:03.179: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 16.16.16.6 (Serial0/1) is down: interface down!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Jul 20 19:57:12.543: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 16.16.16.6 (Serial0/1) is up: new adjacency
Jul 20 19:57:13.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (992/1000), round-trip min/avg/max = 4/44/208 ms在R6上:
R6(config)#int s0/1
R6(config-if)#sh
R6#sh ip route
1.0.0.0/24 is subnetted, 1 subnets
S 1.1.1.0 [200/0] via 192.168.0.1(当s0/1链路失效时就启用备份路由)
6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback0
C 192.168.0.0/24 is directly connected, Ethernet1/1