ATM 点到点配置
很多爱好网络的人员,对ATM都感觉到陌生,因为没有ATM交换机,而无法进行实验,DynamipsGUI也能进行ATM的实验,下面是通过这个软件进行的ATM配置,希望能帮助大家来学习ATM。
在此实验中路由器RA、RB、RC通过ATM交换机相连,他们之间是通过VC进行交换数据,具体VC如拓扑图所示。在此拓扑中采用的是OSPF动态路由协议。
具体配置如下:
RouterA#sh running-config
Building configuration...
Current configuration : 1248 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
interface Loopback0
ip address 11.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface ATM1/0
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.20 point-to-point
ip address 10.1.1.1 255.255.255.0
ip ospf network point-to-point
no snmp trap link-status
pvc 10/10
protocol ip 10.1.1.2 broadcast
encapsulation aal5snap
!
!
interface ATM1/0.30 point-to-point
ip address 10.1.2.1 255.255.255.0
ip ospf network point-to-point
no snmp trap link-status
pvc 11/11
protocol ip 10.1.2.2 broadcast
encapsulation aal5snap
!
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.1.2.0 0.0.0.255 area 0
network 11.1.1.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
End
RouterB#sh running-config
Building configuration...
Current configuration : 965 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
!
interface Loopback0
ip address 12.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface ATM1/0
ip address 10.1.1.2 255.255.255.0
ip ospf network point-to-point
no atm ilmi-keepalive
pvc 20/20
protocol ip 10.1.1.1 broadcast
protocol ip 10.1.1.2 broadcast
encapsulation aal5snap
!
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
!
router ospf 10
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 12.1.1.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end
RouterC#sh running-config
Building configuration...
Current configuration : 932 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterC
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
!
interface Loopback0
ip address 13.1.1.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface ATM1/0
ip address 10.1.2.2 255.255.255.0
ip ospf network point-to-point
no atm ilmi-keepalive
pvc 30/30
protocol ip 10.1.2.1 broadcast
encapsulation aal5snap
!
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
!
router ospf 10
log-adjacency-changes
network 10.1.2.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
End
RouterA# sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
13.1.1.1 0 FULL/ - 00:00:37 10.1.2.2 ATM1/0.30
12.1.1.1 0 FULL/ - 00:00:30 10.1.1.2 ATM1/0.20
RouterA#sh atm pvc
VCD / Peak Avg/Min Burst
Interface Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
1/0.20 6 10 10 PVC SNAP UBR 155000 UP
1/0.30 7 11 11 PVC SNAP UBR 155000 UP
RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, ATM1/0.30
C 10.1.1.0 is directly connected, ATM1/0.20
11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Loopback0
12.0.0.0/32 is subnetted, 1 subnets
O 12.1.1.1 [110/2] via 10.1.1.2, 00:04:25, ATM1/0.20
13.0.0.0/32 is subnetted, 1 subnets
O 13.1.1.1 [110/2] via 10.1.2.2, 00:04:25, ATM1/0.30