hdoj-1028 Ignatius and the Princess III【母函数】

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16744    Accepted Submission(s): 11785


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
   
   
   
   
4 10 20
 

Sample Output
   
   
   
   
5 42 627
 


这道题可以说是母函数入门级的题目,初学者一定要好好品味!!!我昨天一开始接触母函数感觉模板有点怪,今天做这道题就感觉模板很自然。下面是带详细注释的ACcode:


#include<cstdio>
#include<cstring>
#include<cmath>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
int c1[200],c2[200];//c1 表示系数 c2 中间过度变量 
int main(){
	int n;
	while(Si(n)!=EOF){
		int i, j, k;
		//mem(c1, 1);//一开始这样居然不行,有知道原因的望多多指教~ 
		//mem(c2, 0);
		for(i = 0; i <= n; i++)
		{
			c1[i] = 1;c2[i] = 0;//初始化c1为1 代表一开始表达式各变量的系数均为1 
		}
		for(i = 2; i <= n; i++)//从第2个表达式开始一共有n个表达式 
		{
			for(j = 0; j <= n; j++)//J表示进行一次表达式相乘后 第一个表达式的第J个变量 
			{
				for(k = 0; k+j<=n; k+=i)//用第J个变量遍历第2个表达式 
				{
					c2[k+j] += c1[j];//c1[j]是上一次运算结束后一个表达式中指数为j的系数,因为此时第二个表达式中所有的系数均为1,其实就是将遍历过程中k+j指数的系数+1. 
				}
			}
			for(j = 0; j <= n; j++)
			{
				c1[j] = c2[j];//将c2存储的系数值赋给c1 
				c2[j] = 0;//c2清零 
			}
		}
		Pi(c1[n]);
	}
	return 0;
} 




你可能感兴趣的:(hdoj-1028 Ignatius and the Princess III【母函数】)