hdoj 1085 Holding Bin-Laden Captive!【母函数】

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18960    Accepted Submission(s): 8447


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”

hdoj 1085 Holding Bin-Laden Captive!【母函数】_第1张图片

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
   
   
   
   
1 1 3 0 0 0
 

Sample Output
   
   
   
   
4
 



题意:

给出1 2 5三种硬币的数量,求出不能组合出来的最小面额。

思路:

母函数的一道变形题;我们可以依次对1, 1 2, 1 2 5进行处理,最后没有系数的即为最小的数,否则让最大数加 1.

ACcode:

#include<cstdio>
#include<cstring>
#include<cmath>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
int c1[1000], c2[10000];
int main(){
	int n1, n2, n5;
	while(scanf("%d%d%d",&n1, &n2, &n5)==3,n1+n2+n5)
	{
		int n, i, j, k;
		n = n1+n2*2+n5*5;//所能组成的最大的数 
		for(i = 0; i <= n; i++)
		{
			c1[i] = 0;	c2[i] = 0;//初始化 c1 c2 
		} 
		for(i = 0; i <= n1; i++)//只有1的情况 
		{
			c1[i] = 1;
		}
		for(i = 0; i <= n1; i++)//1和2的情况 
		{
			for(j = 0; j <= n2*2; j+=2)
			{
				c2[i+j] += c1[i];
			}
		}
		for(k = 0; k <= n1+n2*2; k++)
		{
			c1[k] = c2[k];c2[k] = 0;
		}
		for(j = 0; j <= n1+n2*2; j++)//1,2,5的情况 
		{
			for(k = 0; k <= n5*5; k+=5)
			{
				c2[k+j] += c1[j];
			}
		}
		for(i = 0; i <= 5*n5+2*n2+n1; i++)
		{
			c1[i] = c2[i];	c2[i] = 0;
		}
		bool f = 0;
		for(i = 0; i <= n; i++)
		{
			if(c1[i]==0)//系数为0 
			{
				Pi(i);f = 1;break; 
			}
		}
		if(!f)
		Pi(n+1);
	}
	return 0;
}





你可能感兴趣的:(hdoj 1085 Holding Bin-Laden Captive!【母函数】)