zoj 1671 Walking Ant 【BFS】

Walking Ant Time Limit: 2 Seconds      Memory Limit: 65536 KB Ants are quite diligent. They sometimes build their nests beneath flagstones.

Here, an ant is walking in a rectangular area tiled with square flagstones, seeking the only hole leading to her nest.

zoj 1671 Walking Ant 【BFS】_第1张图片

The ant takes exactly one second to move from one flagstone to another. That is, if the ant is on the flagstone with coordinates (x,y) at time t, she will be on one of the five flagstones with the following coordinates at time t+1:

(x, y), (x+1, y), (x-1, y), (x, y+1), (x, y-1).

The ant cannot go out of the rectangular area. The ant can visit the same flagstone more than once.

Insects are easy to starve. The ant has to go back to her nest without starving. Physical strength of the ant is expressed by the unit "HP". Initially, the ant has the strength of 6 HP. Every second, she loses 1 HP. When the ant arrives at a flagstone with some food on it, she eats a small piece of the food there, and recovers her strength to the maximum value, i.e., 6 HP, without taking any time. The food is plenty enough, and she can eat it as many times as she wants.

When the ant's strength gets down to 0 HP, she dies and will not move anymore. If the ant's strength gets down to 0 HP at the moment she moves to a flagstone, she does not effectively reach the flagstone: even if some food is on it, she cannot eat it; even if the hole is on that stone, she has to die at the entrance of her home.

If there is a puddle on a flagstone, the ant cannot move there.

Your job is to write a program which computes the minimum possible time for the ant to reach the hole with positive strength from her start position, if ever possible.


Input

The input consists of multiple maps, each representing the size and the arrangement of the rectangular area. A map is given in the following format.

w h
d11 d12 d13 ... d1w
d21 d22 d23 ... d2w
...
dh1 dh2 dh3 ... dhw

The integers w and h are the numbers of flagstones in the x- and y-directions, respectively. w and h are less than or equal to 8. The integer dyx represents the state of the flagstone with coordinates (x, y) as follows.

0: There is a puddle on the flagstone, and the ant cannot move there.
1, 2: Nothing exists on the flagstone, and the ant can move there. `2' indicates where the ant initially stands.
3: The hole to the nest is on the flagstone.
4: Some food is on the flagstone.

There is one and only one flagstone with a hole. Not more than five flagstones have food on them.

The end of the input is indicated by a line with two zeros.

Integer numbers in an input line are separated by at least one space character.


Output

For each map in the input, your program should output one line containing one integer representing the minimum time. If the ant cannot return to her nest, your program should output -1 instead of the minimum time.


Sample Input

3 3
2 1 1
1 1 0
1 1 3
8 4
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
8 5
1 2 1 1 1 1 1 4
1 0 0 0 1 0 0 1
1 4 1 0 1 1 0 1
1 0 0 0 0 3 0 1
1 1 4 1 1 1 1 1
8 7
1 2 1 1 1 1 1 1
1 1 1 1 1 1 1 4
1 1 1 1 1 1 1 1
1 1 1 1 4 1 1 1
4 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 3
8 8
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
1 4 4 1 1 1 1 1
1 4 4 2 1 1 0 0
1 1 0 0 0 0 0 3
1 1 0 4 1 1 1 1
1 1 1 1 1 1 1 1
8 8
1 1 1 1 1 1 1 1
1 1 2 1 1 1 1 1
1 1 4 4 4 1 1 1
1 1 1 4 4 1 0 1
1 1 1 1 1 1 0 1
1 1 1 1 1 1 0 3
1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1
0 0


Sample Output

4
-1
13
20
-1
-1

Source: Asia 1999, Kyoto (Japan)


我要说的  尽在代码中。

/*
题意:在一个N*M的地图上,有5个数字。
0表示此处不可走,
1表示此处可走,
3是蚂蚁的洞穴,
2是蚂蚁开始走的位置,
4表示此处有食物。
现有一个蚂蚁要回家,
它初始只有6HP,
且每走一步会减一,
当HP为0时就会死去,
当它到达食物处可以恢复满HP且该食物可以无限使用。
问蚂蚁最少需要多少步才能到达洞穴,如果到不了输出-1。


思路:BFS + 优先队列。
主要 第一次碰到食物就要把食物从图中消除掉(防止死循环),
因为第一次补给食物后回不了洞穴,
以后再到该位置补给食物也是无济于事的。
*/
#include<stdio.h>
#include<queue>
using namespace std;
int map[9][9];
int h,w;
struct node
{
	int x,y,step,hp;
	friend bool operator  < (node a,node b)
	{
		return a.step > b.step;
	}
};
void BFS(int x,int y)	
{
	priority_queue<node>q;
	int dir[4][2]={1,0,0,-1,0,1,-1,0};
	node  now,next;
	now.x = x;
	now.y = y;
	now.step = 0;
	now.hp = 6;
	q.push(now);
	
	while(!q.empty())
	{
		now = q.top();
		q.pop(); 
		if(map[now.x][now.y] == 3)
		{
			printf("%d\n", now.step);
			return ;
		}
		if(now.hp == 1) continue;
		
		for(int i = 0;i < 4; i++)
		{
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			next.step = now.step + 1; 
			if(next.x>=0&&next.y>=0&&next.x<h&&next.y<w&&map[next.x][next.y])
			{
				if(map[next.x][next.y] == 4)
				{
					next.hp=6;
					map[next.x][next.y] = 1;
				}
				else
					next.hp = now.hp-1;
					q.push(next);
			}
		}
		
	}	
	printf("-1\n");
}

int antx,anty;
int main()
{
	int i,j;
	
	while(scanf("%d%d", &w,&h)!=EOF,h|w)
	{
		for( i = 0;i < h;i++ )
		{
			for( j = 0;j < w;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j] == 2)
				{
					antx = i;
					anty = j;
				}	
			}
		}
		BFS(antx,anty);
	}
	return 0;
}

建议  跟hdoj的1242一起看看  相同点和不同点。相信会有收获。

你可能感兴趣的:(zoj 1671 Walking Ant 【BFS】)