POJ 1995 Raising Modulo Numbers(快速幂,同余定理)

Raising Modulo Numbers
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5510   Accepted: 3193

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

 

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

 

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

 

 

Sample Output

2
13195
13

 

 

题意:输入一个t,表示t组数据,输入m,再输入n,在n后面是n组数据,每组数据有两个数a ,b。输出这n组的a的b次方之和对m

   取余的值。

 

题解:求n组的a的b次方之和对m取余的值,根据同余定理  (a+b)%m=(a%m+b%m)%m   可知就是求n组的a的b次方对m取余的值之和对m取余。   对于a的b次方对m取余的值可以用快速幂模板求出。

 

具体代码如下:

 

 

#include<cstdio>

int pow_mod(int a,int b,int m)//快速幂取模的模板 ,牢记 
{
	int ans,t;
	ans=1;
	t=a%m;
	while(b>0)
	{
		if(b&1)
		  ans=(ans*t)%m;
		b>>=1;
		t=(t*t)%m;
	}
	return ans;
}

int main()
{
	int t,n,m,a,b,sum,cnt,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&m,&n);
		sum=0;
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&a,&b);
			cnt=pow_mod(a,b,m);
			sum=(sum+cnt)%m;
		}
		printf("%d\n",sum);
	}
	return 0;
} 


 

 

 

 

你可能感兴趣的:(POJ 1995 Raising Modulo Numbers(快速幂,同余定理))