Permutation Counting
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1407 Accepted Submission(s): 711
Problem Description
Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N).
Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
Sample Input
Sample Output
1 4
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
虽说是DP水题,但对于渣渣要说实在是不会。所以有幸拜访了Kuangbin大神的博客。。。。。
题意:给出数字n和k,问有多少个数列满足有k个数且这这些数比数字本身对应的下标的值大。
解题思路:dp[i][j]表示i个数的排列中E值为j的个数。假设现在已有一个E值为j的i的排列,对于新加入的一个数i+1,将其加入排列的方法有三:1)把它放最后,加入后E值不变 2)把它和一个满足A[k]>k的数交换,交换后E值不变 3)把它和一个不满足A[k]>k的数交换,交换后E值+1 根据这三种方法得到转移方程dp[i][j] = dp[i - 1][j] + dp[i - 1][j] * j + dp[i - 1][j - 1] * (i - j);
具体代码:
#include<stdio.h>
#define mod 1000000007
__int64 dp[1010][1010];//不能用int数组,数列的个数会很大
int main()
{
int n,k,i,j;
for(i=1;i<=1000;i++)
{
dp[i][0]=1;
for(j=1;j<i;j++)//不存在n与k值相等的数列
dp[i][j]=(dp[i-1][j]+dp[i-1][j]*j+dp[i-1][j-1]*(i-j))%mod;
}
while(scanf("%d%d",&n,&k)!=EOF)
printf("%d\n",dp[n][k]);
return 0;
}