hdu 1200 To and Fro

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4653    Accepted Submission(s): 3248


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
   
   
   
   
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
   
   
   
   
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
 /*题解:
解题思路:将一个字符串存入二维数组里(若行号是从零开始,则行号为奇数是正序,行号为偶数时逆序,详情见下图),

例如:输入toioynnkpheleaigshareconhtomesnlewx,输入到二维数组的顺序 
hdu 1200 To and Fro_第1张图片
输出时,列不变,行从上往下输出(j变i不变),形如:

*/
<pre name="code" class="cpp">#include<cstdio>
#include<cstring>
int main()
{
    int n,i,j,k,len,t;
    char a[1010][1010],s[1010];
    while(scanf("%d",&n)&&n)
	{
        scanf("%s",s);
        len=strlen(s);
        t=len/n;           //t为行数 
        k=0;
        for(i=1; i<=t; i++)
		{
            if(i%2==1)
			{
                for(j=1; j<=n; j++)
                a[i][j]=s[k++];
            }
            else
			{
                for(j=n; j>=1; j--)
                a[i][j]=s[k++];
            }
        } 
        for(j=1; j<=n; j++)
		{
            for(i=1; i<=len/n; i++)
			{
                printf("%c",a[i][j]);
            }
        }
        printf("\n");
    }
    return 0;
}


 
 


你可能感兴趣的:(c,字符串,HDU,杭电)