ZOJ 3469 Food Delivery

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3469

Food Delivery

Time Limit: 2 Seconds Memory Limit: 65536 KB

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input


The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output


For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input


5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output


55

Author: LI, Cheng
Contest: ZOJ Monthly, February 2011

大意——一条直线上,有一些需要送饭的客户,每一个客户有一个位置以及不满意度,随着时间的增加而增加。问:给你餐馆的位置,送餐速度以及客户的位置及不满意度,求送餐完毕时所有客户最小的不满意度。

思路——显然这是一个dp问题,但如何表示其状态呢?设dp[i][j][k]表示i~j区间内外卖送完后的最小不满意度,当k=0时表示停在i点;当k=1时表示停在j点。那么得到状态转换如下:
dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][0]+(sum[i]+sum[n]-sum[j])*(order[i+1].x-order[i].x))
dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][1]+(sum[i]+sum[n]-sum[j])*(order[j].x-order[i].x))
dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][0]+(sum[i-1]+sum[n]-sum[j-1])*(order[j].x-order[i].x))
dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][1]+(sum[i-1]+sum[n]-sum[j-1])*(order[j].x-order[j-1].x))
其中符号表示:sum[i]代表前i个客户的不满意度,order[i].x代表第i个客户的位置。最终,min(dp[1][n][0], dp[1][n][1])即为客户总的最小不满意度,乘以送餐速度即为结果。
复杂度分析——时间复杂度:O(n^2),空间复杂度:O(n^2)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <iomanip>
#include <string>
#include <cstring>
#include <climits>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int maxn = 1005;
const int inf = 0x3f3f3f3f;
int dp[maxn][maxn][2];
int sum[maxn];
int X, V, n;
struct person
{
    int x, b;
} order[maxn];

bool cmp(person a, person b);

int main()
{
    ios::sync_with_stdio(false);
    while (cin >> n >> V >> X)
    {
        for (int i=1; i<=n; i++)
            cin >> order[i].x >> order[i].b;
        n++;
        order[n].x = X;
        order[n].b = 0;
        sort(order+1, order+n+1, cmp);
        int temp;
        for (int i=1; i<=n; i++)
            if (order[i].x == X)
            {
                temp = i;
                break;
            }
        for (int i=1; i<=n; i++)
            for (int j=1; j<=n; j++)
                dp[i][j][0] = dp[i][j][1] = inf;
        dp[temp][temp][0] = dp[temp][temp][1] = 0;
        sum[0] = 0;
        for (int i=1; i<=n; i++)
            sum[i] = sum[i-1]+order[i].b;
        for (int i=temp; i>=1; i--)
            for (int j=temp; j<=n; j++)
            {
                if (i == j)
                    continue;
                dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][0]+(sum[i]+sum[n]-sum[j])*(order[i+1].x-order[i].x));
                dp[i][j][0] = min(dp[i][j][0], dp[i+1][j][1]+(sum[i]+sum[n]-sum[j])*(order[j].x-order[i].x));
                dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][0]+(sum[i-1]+sum[n]-sum[j-1])*(order[j].x-order[i].x));
                dp[i][j][1] = min(dp[i][j][1], dp[i][j-1][1]+(sum[i-1]+sum[n]-sum[j-1])*(order[j].x-order[j-1].x));
            }
        cout << min(dp[1][n][0], dp[1][n][1])*V << endl;
    }
    return 0;
}

bool cmp(person a, person b)
{
    return a.x < b.x;
}


你可能感兴趣的:(ZOJ,区间DP)