HDOJ 1789 Doing Homework again(贪心,好题)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8730    Accepted Submission(s): 5157


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
   
   
0 3 5
 


题意不难懂。先按照扣除学分的分值从大到小排序,再对天数经行操作,标记能在规定天数内完成的学科。将不能完成的学科学分相加即可。具体代码如下:

 

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct stu
{
	int d;
	int s;
}a[1010];

int cmp(stu a,stu b)
{
	  return a.s>b.s;  
}

int main()
{
	int t,n,i,j,mark[1010],count,sign;
	scanf("%d",&t);
	while(t--)
	{
		memset(mark,0,sizeof(mark));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		  scanf("%d",&a[i].d);
		for(i=0;i<n;i++)
		  scanf("%d",&a[i].s);
		sort(a,a+n,cmp);
		count=0;
	    for(i=0;i<n;i++)
	    {
	    	sign=0;
	    	for(j=a[i].d;j>0;j--)
	    	{
	    		if(mark[j]==0)
	    		{
	    			mark[j]=1;//标记完成的学科,和用掉的整天 
	    			sign=1;
	    			break;
	    		}
	    	}
	    	if(!sign)
	    	  count+=a[i].s;
	    }
	    printf("%d\n",count);
	}
	return 0;
}


 

你可能感兴趣的:(HDOJ 1789 Doing Homework again(贪心,好题))