POJ 3277 City Horizon 线段树+离散化

POJ 3277 City Horizon 线段树+离散化

Description

Farmer John has taken his cows on a trip to the city! As the sun sets, the cows gaze at the city horizon and observe the beautiful silhouettes formed by the rectangular buildings.

The entire horizon is represented by a number line with N (1 ≤ N ≤ 40,000) buildings. Building i's silhouette has a base that spans locations Ai through Bi along the horizon (1 ≤ Ai < Bi ≤ 1,000,000,000) and has height Hi (1 ≤ Hi ≤ 1,000,000,000). Determine the area, in square units, of the aggregate silhouette formed by all N buildings.

Input

Line 1: A single integer: N
Lines 2.. N+1: Input line i+1 describes building i with three space-separated integers: Ai, Bi, and Hi

Output

Line 1: The total area, in square units, of the silhouettes formed by all N buildings

Sample Input

4
2 5 1
9 10 4
6 8 2
4 6 3

Sample Output

16

Hint

The first building overlaps with the fourth building for an area of 1 square unit, so the total area is just 3*1 + 1*4 + 2*2 + 2*3 - 1 = 16.

Source

USACO 2007 Open Silver
    题目的意思是说:平面上有[1,40000]个建筑,每个建筑有一个区间[Ai,Bi]表示它的跨度,Hi表示其高度。要求这n个建筑的平面覆盖面积。
由于Ai,Bi∈[1,1000000000],直接将线段[Ai,Bi]插入线段树空间消耗太大,可以将这n条线段的2n个端点离散化到一个数组X[0...2n-1],然后再将其插入线段树,最后求出面积。
#include  < iostream >
using   namespace  std;

const   int  MAXN  =   40010 ;
struct  segment {
    
int left,right,h;
}
tree[MAXN * 3 ];
int  pos[MAXN][ 3 ],x[MAXN * 2 ],len;

int  cmp1( const   void   * a, const   void   * b) {
    
return *(int *)a-*(int *)b;
}

int  cmp2( const   void   * a, const   void   * b) {
    
return *((int *)a+2)-*((int *)b+2);
}

int  query( int  h) {
    
int low=0,high=len-1,mid;
    
while(low<=high){
        mid
=(low+high)>>1;
        
if(x[mid]==h) return mid;
        
else if(x[mid]>h) high=mid-1;
        
else low=mid+1;
    }

    
return -1;
}

void  create( int  l, int  r, int  index) {
    tree[index].left
=l,tree[index].right=r;
    tree[index].h
=0;
    
if(r==l+1return;
    
int mid=(l+r)>>1;
    create(l,mid,
2*index);
    create(mid,r,
2*index+1);
}

void  update( int  l, int  r, int  h, int  index) {
    
if(h<tree[index].h) return;
    
if(l==tree[index].left && r==tree[index].right){
        tree[index].h
=h;
        
return;
    }

    
if(tree[index].h>=0 && tree[index].right>tree[index].left+1){
        tree[
2*index].h=tree[2*index+1].h=tree[index].h;
        tree[index].h
=-1;
    }

    
int mid=(tree[index].left+tree[index].right)>>1;
    
if(r<=mid)
        update(l,r,h,
2*index);
    
else if(l>=mid)
        update(l,r,h,
2*index+1);
    
else{
        update(l,mid,h,
2*index);
        update(mid,r,h,
2*index+1);
    }

}

long   long  cal( int  index) {
    
if(tree[index].h>=0)
        
return tree[index].h*(long long)(x[tree[index].right]-x[tree[index].left]);
    
else
        
return cal(2*index)+cal(2*index+1);
}

int  main() {
    
int n,i,k,l,r;
    scanf(
"%d",&n);
    
for(i=len=0;i<n;i++,len+=2){
        scanf(
"%d %d %d",&pos[i][0],&pos[i][1],&pos[i][2]);
        x[len]
=pos[i][0],x[len+1]=pos[i][1];
    }

    qsort(x,
2*n,sizeof(int),cmp1);
    
for(i=1,k=0;i<2*n;i++)
        
if(x[i]!=x[i-1]) x[k++]=x[i-1];
    x[k
++]=x[i-1],len=k;
    qsort(pos,n,
3*sizeof(int),cmp2);
    create(
0,len-1,1);
    
for(i=0;i<n;i++){
        l
=query(pos[i][0]),r=query(pos[i][1]);
        update(l,r,pos[i][
2],1);
    }

    printf(
"%I64d\n",cal(1));
    
return 0;
}

你可能感兴趣的:(POJ 3277 City Horizon 线段树+离散化)