POJ2260:Error Correction

Description

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:
1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.

Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".

Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt
/*
题目意思不难理解,就是要每行每列加起来都是偶数,就输出OK
如果不是,通过改变其中的一个值能够达到其要求就输出改变那个坐标
否则就输出Corrupt
我的思路是将每行的和与每列的和都别丢入数组中,如果其中某个数组的奇数超过
1个,那肯定就不行了
如果都是偶数就不用说了
如果刚好每个数组都有一个奇数,输出者两个奇数所在地就是改变的坐标

比如
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1

行之和数组:b : 2 1 4 2
列之和数组:C :2 2 3 2
所以改变的坐标是(2,3)
*/

#include <iostream>
using namespace std;

int main()
{
    int a[105][105],b[105],c[105],i,j,n,sum;

    while(cin >> n,n)
    {
        for(i = 0; i<n; i++)
        {
            for(j = 0; j<n; j++)
            {
                cin >> a[i][j];
            }
        }
        int cnt = 0;
        for(i = 0; i<n; i++)
        {
            b[i] = 0;
            for(j = 0; j<n; j++)
            {
                b[i]+=a[i][j];
            }
        }
        for(i = 0; i<n; i++)
        {
            c[i] = 0;
            for(j = 0; j<n; j++)
            {
                c[i]+=a[j][i];
            }
        }
        int sum1=0,sum2 = 0,flag1,flag2;
        for(i = 0; i<n; i++)
        {
            if(b[i]%2)
            {
                sum1++;
                flag1 = i;
            }
        }
        for(i = 0; i<n; i++)
        {
            if(c[i]%2)
            {
                sum2++;
                flag2 = i;
            }
        }
        if(sum1 > 1 || sum2>1)
            cout << "Corrupt" << endl;
        else if(!sum1 && !sum2)
            cout << "OK" << endl;
        else
            cout << "Change bit (" << flag1+1 << "," << flag2+1 << ")" << endl;
    }

    return 0;
}

你可能感兴趣的:(ACM,poj,解题报告)