PIGS
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 10400 |
|
Accepted: 4540 |
Description
Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs.
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer arives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.
Input
The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.
Output
The first and only line of the output should contain the number of sold pigs.
Sample Input
3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6
Sample Output
7
Source
Croatia OI 2002 Final Exam - First day
题目: http://poj.org/problem?id=1149
分析:这题一开始打算用猪圈作为点入手,然后用分层图来做,但是这样的点太多,还有复杂度太高,就没去尝试了,有谁这样过的和我分享下哈。。。
转个角度来分析,把每个卖猪的人作为点,当前来买猪的人如果先前买猪的人打开相同的猪圈,则先前那个人可以把所有能开的猪圈里的猪留给它,也就是在他们之间连一条无穷大的边,然后,如果是第一个开某个猪圈的人,就在源点与某人直接连上容量为猪圈中猪的数量的边,每个人与汇连上一条容量为它想买猪的数量的边,此时求最大流,最大流即答案。
描述是在是挫阿~~~看代码好理解
代码:
#include<cstdio>
using namespace std;
const int mm=2222222;
const int mn=2222;
const int oo=1000000000;
int node,src,dest,edge;
int ver[mm],flow[mm],next[mm];
int head[mn],work[mn],dis[mn],q[mn],num[mn];
int last[11111];
inline int min(int a,int b)
{
return a<b?a:b;
}
inline void prepare(int _node,int _src,int _dest)
{
node=_node,src=_src,dest=_dest;
for(int i=0;i<node;++i)head[i]=-1;
edge=0;
}
inline void addedge(int u,int v,int c)
{
ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs()
{
int i,u,v,l,r=0;
for(i=0;i<node;++i)dis[i]=-1;
dis[q[r++]=src]=0;
for(l=0;l<r;++l)
for(i=head[u=q[l]];i>=0;i=next[i])
if(flow[i]&&dis[v=ver[i]]<0)
{
dis[q[r++]=v]=dis[u]+1;
if(v==dest)return 1;
}
return 0;
}
int Dinic_dfs(int u,int exp)
{
if(u==dest)return exp;
for(int &i=work[u],v,tmp;i>=0;i=next[i])
if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
{
flow[i]-=tmp;
flow[i^1]+=tmp;
return tmp;
}
return 0;
}
int Dinic_flow()
{
int i,ret=0,delta;
while(Dinic_bfs())
{
for(i=0;i<node;++i)work[i]=head[i];
while(delta=Dinic_dfs(src,oo))ret+=delta;
}
return ret;
}
int main()
{
int i,j,k,n,m;
while(scanf("%d%d",&m,&n)!=-1)
{
for(i=1;i<=m;++i)last[i]=0,scanf("%d",&num[i]);
prepare(n+2,0,n+1);
for(i=1;i<=n;++i)
{
scanf("%d",&k);
while(k--)
{
scanf("%d",&j);
if(!last[j])addedge(src,i,num[j]);
else addedge(last[j],i,oo);
last[j]=i;
}
scanf("%d",&k);
addedge(i,dest,k);
}
printf("%d\n",Dinic_flow());
}
return 0;
}