HDU 5477 A Sweet Journey(本场的最水题,过程处理好是关键)——2015 ACM/ICPC Asia Regional Shanghai Online

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 47    Accepted Submission(s): 23


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

HDU 5477 A Sweet Journey(本场的最水题,过程处理好是关键)——2015 ACM/ICPC Asia Regional Shanghai Online_第1张图片
 

Input
In the first line there is an integer t ( 1t50    ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:  Li,Ri , which represents the interval  [Li,Ri]    is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means  Ri<Li+1  for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
   
   
   
   
1 2 2 2 5 1 2 3 4
 

Sample Output
   
   
   
   
Case #1: 0
 

Source
2015 ACM/ICPC Asia Regional Shanghai Online
 
/*********************************************************************/

题意:一条长L的路,区间为[0,L],这条路上有陆地和沼泽。当在陆地上行走,每走过x的距离会恢复B*x的体力;当在沼泽上行走时,每走过x的距离会消耗A*x的体力,问一开始至少需要多少体力才能通过这条长L的路。

其实这题只要一个个沼泽处理一遍就可以了,毕竟题目给出的沼泽是不会重叠,而且是递增的(Ri<Li+1)

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<stdlib.h>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
using namespace std;
const int N = 105;
const int inf = 1000000000;
const int mod = 2009;
int l[N],r[N];
int main()
{
    int t,n,A,B,L,i,k,Max,m,p=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&A,&B,&L);
        for(m=Max=i=0;i<n;i++)
            scanf("%d%d",&l[i],&r[i]);
        for(k=i=0;i<n;i++)
        {
            m=m+B*(l[i]-k)-A*(r[i]-l[i]);//当前体力值
            Max=max(Max,-m);
            k=r[i];
        }
        printf("Case #%d: %d\n",p++,Max);
    }
    return 0;
}
菜鸟成长记

你可能感兴趣的:(ACM)