ZOJ Problem Set - 1797 Least Common Multiple(最小公倍数)

/*

ZOJ Problem Set - 1797

Least Common Multiple

Time Limit: 1 Second      Memory Limit: 32768 KB

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input

 

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

 

Output

 

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

 

Sample Input

 

2

3 5 7 15

6 4 10296 936 1287 792 1

 

 

Sample Output

 

105

10296

*/

 

继续来做道差不多的题,两数之积除以他们的最大公约数就是最小公倍数

 

#include <iostream>

using namespace std;

typedef unsigned int UINT;

 

UINT lcm(UINT a, UINT b)

{

    UINT m,n,r;

if(a<b)a^=b,b^=a,a^=b;

r=a%b;

m=a;

n=b;

while(r)

{

a=b;

b=r;

r=a%b;

}            //此处gcd法求出最大公约数

return m/b*n;   // 两数之积除以最大公约数就是最小公倍数 

}

 

int main()

{

    int in;

    while(cin>>in)

    {

        while(in--)

        {    

            UINT num,a,b;

            cin>>num;

            cin>>a;

            for(UINT i=0;i<num-1;++i)

            {

                cin>>b;

                a=lcm(a,b);

            }

            cout<<a<<endl;

        }

    }

    return 0;

}

你可能感兴趣的:(Integer,input,each,n2,output,Numbers)