POJ2352:Stars

点击打开题目链接


Stars

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25602   Accepted: 11189

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
POJ2352:Stars_第1张图片
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

=====================================题目大意=====================================


一颗星星的等级是指位于它左下方的星星的数量。

给出N个星星的坐标,星星是按照Y坐标升序(Y坐标相等时按照X坐标升序)给出的,分行输出等级为0,1,2,......,N-1的星

星的数量


=====================================算法分析=====================================


线段树(树状数组)。

由于星星是按照Y坐标升序(Y坐标相等时按照X坐标升序)给出的,所以当前星星的等级就是之前给出的星星中位于它左边的星星

的数量

因此这里根本不需要考虑Y轴,只需对X轴建立单点更新单点查询的线段树或者建立树状数组即可。


=======================================代码=======================================


1、线段树




#include<stdio.h>
#include<string.h>

#define LSON(N)      ((N)<<1  )           
#define RSON(N)      ((N)<<1|1)                
#define MID(L,R)     (((L)+(R))>>1)              

const int MAXC=32005;

int N,Level[MAXC],SegmTree[MAXC<<2];

void Build()
{
	memset(SegmTree,0,sizeof(SegmTree));
}

void Insert(int Ins,int L,int R,int N)     
{
	++SegmTree[N];
	if(L!=R)
	{
		int M=MID(L,R);
		if(Ins<=M) Insert(Ins,L,M,LSON(N));
		else Insert(Ins,M+1,R,RSON(N));
	}
}

int Query(int Que,int L,int R,int N)     
{
    if(Que<L)  return 0;
	if(R<=Que) return SegmTree[N];
	int M=MID(L,R);
    return Query(Que,L,M,LSON(N))+Query(Que,M+1,R,RSON(N));
}

int main()
{
	while(scanf("%d",&N)==1)
	{
		Build();
	    memset(Level,0,sizeof(Level));
		for(int i=0;i<N;++i)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			++Level[Query(x,0,32000,1)];
			Insert(x,0,32000,1);
		}
		for(int i=0;i<N;++i) 
		{
			printf("%d\n",Level[i]);
		}
	}
	return 0;
}


2、树状数组




#include<stdio.h>
#include<string.h>

#define LOWBIT(N) ((N)&(-(N)))

const int MAXC=32005;

int N,Level[MAXC],BinTree[MAXC];

void Build()
{
	memset(BinTree,0,sizeof(BinTree));
}

void UpDate(int N)
{
    while(N<=MAXC)
    {
        ++BinTree[N];
        N+=LOWBIT(N);
    }
}

int GetSum(int N)
{
    int sum=0;
    while(N)
    {
        sum+=BinTree[N];
        N-=LOWBIT(N);
    }
    return sum;
}

int main()
{
	while(scanf("%d",&N)==1)
	{
		Build();
	    memset(Level,0,sizeof(Level));
		for(int i=0;i<N;++i)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			++Level[GetSum(x+1)];
			UpDate(x+1);
		}
		for(int i=0;i<N;++i) 
		{
			printf("%d\n",Level[i]);
		}
	}
	return 0;
}

你可能感兴趣的:(数据结构,线段树,树状数组)