武汉科技大学计算机学院菜鸟杯:Picture (杭电2052)

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11187    Accepted Submission(s): 5791


Problem Description
Give you the width and height of the rectangle,darw it.

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.

Sample Input
   
   
   
   
3 2

Sample Output
+---+
|   |
|   |
+---+

 

 

代码如下:

#include<stdio.h>

int main()
{
    int i,j,n,m;
    while (scanf("%d%d",&n,&m)!=EOF)
    {
        printf("+");
        for (i=1;i<=n;i++)
          printf("-");
        printf("+");
        printf("\n");
        for (i=1;i<=m;i++)
        {
            printf("|");
            for (j=1;j<=n;j++)
                printf(" ");
            printf("|\n");
        }
        printf("+");
        for (i=1;i<=n;i++)
          printf("-");
        printf("+\n");
        printf("\n");
    }
    return 0;
}


 

你可能感兴趣的:(武汉科技大学计算机学院菜鸟杯:Picture (杭电2052))