Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
深搜水题
#include <stdio.h>
#include <string.h>
int n,m,cnt;
char map[30][30];
int to[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
void dfs(int i,int j)
{
cnt++;
map[i][j] = '#';
for(int k = 0; k<4; k++)
{
int x = i+to[k][0];
int y = j+to[k][1];
if(x<n && y<m && x>=0 && y>=0 && map[x][y] == '.')
dfs(x,y);
}
return;
}
int main()
{
int i,j,fi,fj;
while(~scanf("%d%d%*c",&m,&n))
{
if(m == 0 && n == 0)
break;
for(i = 0; i<n; i++)
{
for(j = 0; j<m; j++)
{
scanf("%c",&map[i][j]);
if(map[i][j] == '@')
{
fi = i;
fj = j;
}
}
getchar();
}
cnt = 0;
//map[i][j] = '#';
dfs(fi,fj);
printf("%d\n",cnt);
}
return 0;
}