HDOJ 1085 Holding Bin-Laden Captive!(母函数)



Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18962    Accepted Submission(s): 8448


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
   
   
   
   
1 1 3 0 0 0
 

Sample Output
   
   
   
   
4
 
题意: 有三种面值的钱币1 , 2 ,5 元,数量分别为num_1,num_2,num_3。求这些钱币不能组成的最小面值。

题解:母函数问题,找到系数为0的最小指数即可。

代码如下:

#include<cstdio>
#include<cstring>
#define maxn 8010
int c1[maxn],c2[maxn];
int main()
{
	int num[4],val[4],i,j,k,sum,used;
	while(scanf("%d%d%d",&num[1],&num[2],&num[3])&&num[1]||num[2]||num[3])
	{
		memset(c1,0,sizeof(c1));//注意对c1数组的清零 
		sum=num[1]+num[2]*2+num[3]*5+1;
		for(i=0;i<=num[1];++i)
			c1[i]=1;
		memset(c2,0,sizeof(c2));
		val[2]=2; val[3]=5;
		for(i=2;i<=3;++i)
		{
			for(j=0;j<sum;++j)
			{
				for(k=0,used=0;k+j<sum&&used<=num[i];k+=val[i],used++)//每个面值的钱币使用不超过num[i] 
					c2[k+j]+=c1[j];
			}
			for(j=0;j<sum;++j)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		for(j=0;j<=sum;++j)
		{
			if(c1[j]==0)
			{
				printf("%d\n",j);
				break;
			}
		}
	}
	return 0;
} 

你可能感兴趣的:(HDOJ 1085 Holding Bin-Laden Captive!(母函数))