POJ 2632 Crashing Robots

Crashing Robots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5755   Accepted: 2508

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
POJ 2632 Crashing Robots_第1张图片 
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

Source

Nordic 2005
模拟题,写起来有点麻烦而已,不难,注意坐标!!
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
int a,b,n,m,num,step,p[200][200],rep,v;
char c;
struct node
{
    int x,y,d;
} r[200];
void go()
{
    p[r[num].x][r[num].y]=0;
    for(int j=0; j<step; j++)
    {
        if(c=='F')
        {
            switch(r[num].d)
            {
            case 0:
                r[num].x--;
                break;
            case 1:
                r[num].y++;
                break;
            case 2:
                r[num].x++;
                break;
            case 3:
                r[num].y--;
                break;
            default:
                break;
            }
            if(p[r[num].x][r[num].y])
            {
                printf("Robot %d crashes into robot %d\n",num,p[r[num].x][r[num].y]);
                rep=1;
                return;
            }
            else if(r[num].x>a||r[num].x<=0||r[num].y>b||r[num].y<=0)
            {
                printf("Robot %d crashes into the wall\n",num);
                rep=1;
                return;
            }
        }
        else if(c=='L')
        {
            r[num].d++;
        }
        else if(c=='R')
        {
            r[num].d--;
        }
    }
    p[r[num].x][r[num].y]=num;
    while(r[num].d<0)
    {
        r[num].d+=4;
    }
    r[num].d=r[num].d%4;
}
int main()
{
    map<char,int>dir;
    dir['S']=0;
    dir['E']=1;
    dir['N']=2;
    dir['W']=3;
    int k;
    scanf("%d",&k);
    while(k--)
    {
        memset(p,0,sizeof(p));
        rep=0;
        scanf("%d%d",&b,&a);
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d %c",&r[i].y,&r[i].x,&c);
            r[i].d=dir[c];
            p[r[i].x][r[i].y]=i;
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d %c%d",&num,&c,&step);
            if(rep==0)
            {
                go();
            }
        }
        if(rep==0)
        {
            cout<<"OK"<<endl;
        }
    }
    return 0;
}


你可能感兴趣的:(POJ 2632 Crashing Robots)