hdu1022(Train Problem I)----- 典型栈类题目

点击打开链接

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
hdu1022(Train Problem I)----- 典型栈类题目_第1张图片 hdu1022(Train Problem I)----- 典型栈类题目_第2张图片 hdu1022(Train Problem I)----- 典型栈类题目_第3张图片
 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input

   
   
   
   
3 123 321 3 123 312
 

Sample Output

   
   
   
   
Yes. in in in out out out FINISH No. FINISH

题意:就是说给一个火车进站的序列,然后再给你一个火车出站的序列,而火车站最多能停n列火车,问是否能按所给的序列号让火车出站。

注:并不是非要让所有进站的火车全部进来才能出站,只是如果火车站进了多列火车,后进来的必须先出,这就是栈:后进先出


package stack;

import java.util.Scanner;

public class P1022 {
	static int n;
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		char[] in,out;
		String s;
		String[] path;
		int count,j;
		while(sc.hasNext()){
			n=sc.nextInt();
			s=sc.next();
			in=s.toCharArray();
			s=sc.next();
			out=s.toCharArray();
			path=new String[n*2];
			count=0;j=0;
			TrainStack trainStack=new TrainStack(n);
			for(int i=0;i<n;i++){
				trainStack.inStack(in[i]);
				path[count++]="in";//存操作方式,是进还是出
				while(!trainStack.isEmpty()&&j<n&&trainStack.getTop()==out[j]){//按要求序列出站
					path[count++]="out";
					trainStack.outStack();
					j++;
				}
			}
			if(trainStack.isEmpty()){//若栈为空,则表示按要求序列将所有火车出站
				System.out.println("Yes.");
				for(int i=0;i<count;i++){
					System.out.println(path[i]);
				}
			}else{
				System.out.println("No.");
			}
			System.out.println("FINISH");
		}
	}

}

class TrainStack{
	int top=0;
	char[] stack;
	public TrainStack(int n){
		stack=new char[n];
	}
	public char getTop() {//获得栈顶数据
		return stack[top-1];
	}
	public void inStack(char ch){//进栈
		stack[top++]=ch;
	}
	public void outStack(){//出栈
		if(isEmpty()){
			return ;
		}
		top--;
	}
	public boolean isEmpty(){//判断栈是否为空
		if(top==0){
			return true;
		}
		return false;
	}
}





你可能感兴趣的:(hdu1022)