hdu1022 Train Problem I 栈的应用

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29193    Accepted Submission(s): 11080


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
hdu1022 Train Problem I 栈的应用_第1张图片 hdu1022 Train Problem I 栈的应用_第2张图片 hdu1022 Train Problem I 栈的应用_第3张图片
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
   
   
   
   
3 123 321 3 123 312
 

Sample Output
   
   
   
   
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".


#include <cstdio>
#include <iostream>
#include <cstring>
#include <stack>

using namespace std;

int main()
{
	int n, lenb, len;
	bool flag[20];  //用于标记出入栈情况
	char a[20], b[20];
	stack<char> s;
	while (~scanf("%d%s%s", &n, a, b)) {
		memset(flag, false, sizeof(flag));
		while (!s.empty()) s.pop();
		len = lenb = 0;
		for (int i = 0; i < n; i++) {
			s.push(a[i]);
			flag[len++] = true;

			//遇到符合b中序列顺序的才出栈标记,否则继续入栈
			while (!s.empty() && s.top() == b[lenb]) {
				s.pop();
				flag[len++] = false;
				lenb++;
			}
		}
		//最后看b这个序列是否都匹配了
		if (lenb == n) {
			puts("Yes.");
			for (int i = 0; i < len; i++) {
				if (flag[i]) {
					puts("in");
				}
				else {
					puts("out");
				}
			}
		}
		else {
			puts("No.");
		}
		puts("FINISH");
	}
	return 0;
}



你可能感兴趣的:(算法,栈,ACM)