GT and numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 262 Accepted Submission(s): 75
Problem Description
You are given two numbers
N and
M .
Every step you can get a new
N in the way that multiply
N by a factor of
N .
Work out how many steps can
N be equal to
M at least.
If N can't be to M forever,print
−1 .
Input
In the first line there is a number
T .
T is the test number.
In the next
T lines there are two numbers
N and
M .
T≤1000 ,
1≤N≤1000000 ,
1≤M≤263 .
Be careful to the range of M.
You'd better print the enter in the last line when you hack others.
You'd better not print space in the last of each line when you hack others.
Output
For each test case,output an answer.
Sample Input
Sample Output
Source
BestCoder Round #60
题意:每个n都可以乘上一个自己的因子,求最少乘几次能得到m。
分析:
如果AAA大于BBB那么显然无解。
考虑把AAA和BBB分解质因数。
若BBB存在AAA没有的质因数也显然无解。
对于某一个AAA的质因数的次数。为了加速接近BBB,它一定是每次翻倍,最后一次的时候把剩下的加上。
那么答案就是最小的kkk使得2k∗Anum≥Bnum2^{k}*A_{num} \geq B_{num}2k∗Anum≥Bnum。
最后把每个质因数的答案max起来即可。(B可以是2^63,这样就得用unsigned long long了,这是个坑点)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))
unsigned ll n,m;
ll gcd(ll a, ll b)
{
if(a%b)
return gcd(b, a%b);
return b;
}
int main()
{
int T;
cin>>T;
while(T--)
{
cin>>n>>m;
int ans=0;
while(n!=m)
{
if(m%n){cout<<"-1"<<endl; break;}
ll k=gcd(m/n, n);
if(k==1){cout<<"-1"<<endl; break;}
n*=k;
ans++;
}
if(n==m) cout<<ans<<endl;
}
return 0;
}
2632^{63这样就要开unsigned long long。