Coins (多重背包,较好的题)

1、http://acm.hdu.edu.cn/showproblem.php?pid=2844

2、此题,主要注意优化,只用二进制优化,还是超时,ac的方法是将多重背包分成完全背包和01背包,01背包中再用二进制优化,

题目大意:

Whuacmers有n中硬币,价值分别为A1,A2,A3...An ,每种硬币的个数为C1,C2,C3...Cn,要求的是从1到m,这些硬币可以凑成多少种价值,即有多少个dp[i]==i;

3、题目:

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3969    Accepted Submission(s): 1578


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.


 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.


 

Output
For each test case output the answer on a single line.


 

Sample Input
   
   
   
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0


 

Sample Output
   
   
   
   
8 4


 

4、ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
int v[110];
int w[110];
int dp[100005];
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        for(int i=1;i<=100005;i++)
        dp[i]=-9999999;
        dp[0]=1;
        for(int i=1; i<=n; i++)
            scanf("%d",&v[i]);
        for(int i=1; i<=n; i++)
            scanf("%d",&w[i]);
        for(int i=1; i<=n; i++)
        {
            if(v[i]*w[i]>=m)
            {
                for(int j=v[i]; j<=m; j++)
                {
                    dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
                    //printf("%d %d\n",j,dp[j]);
                }
            }
            else
            {
                for(int k=1; k<=w[i]; k=k*2)
                {
                    for(int j=m; j>=v[i]*k; j--)
                    {
                        dp[j]=max(dp[j],dp[j-v[i]*k]+v[i]*k);
                    }
                     w[i]-=k;
                }
                if(w[i]>0)
                {
                    for(int j=m; j>=v[i]*w[i]; j--)
                        dp[j]=max(dp[j],dp[j-v[i]*w[i]]+v[i]*w[i]);
                }
            }
        }
        int count=0;
        for(int i=1; i<=m; i++)
        {
            if(dp[i]>=0)
                count++;
        }
        printf("%d\n",count);
    }
    return 0;
}


 

5、只用二进制优化超时的代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
int v[110];
int w[110];
int dp[100005];
int visit[100005];
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
        break;
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        memset(dp,0,sizeof(dp));
        memset(visit,0,sizeof(visit));
        for(int i=1;i<=n;i++)
        scanf("%d",&v[i]);
        int k=n;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&w[i]);
            for(int j=1;j<=w[i];j=j*2)
            {
                 v[k++]=v[i]*j;
                 w[i]-=j;
            }
            if(w[i]>0)
            {
                v[k++]=v[i]*w[i];
            }
        }
        int count=0;
        for(int i=1;i<=k;i++)
        {
            for(int j=m;j>=1;j--)
            {
                if(j>=v[i])
                dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
                if(dp[j]==j&&visit[j]==0)
                {
                    count++;
                    visit[j]=1;
                }
            }
        }
        printf("%d\n",count);
    }
    return 0;
}
/*
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
*/


 

 

你可能感兴趣的:(Coins (多重背包,较好的题))