Victor and World
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 385 Accepted Submission(s): 160
Problem Description
After trying hard for many years, Victor has finally received a pilot license. To have a celebration, he intends to buy himself an airplane and fly around the world. There are
n countries on the earth, which are numbered from
1 to
n . They are connected by
m undirected flights, detailedly the
i -th flight connects the
ui -th and the
vi -th country, and it will cost Victor's airplane
wi L fuel if Victor flies through it. And it is possible for him to fly to every country from the first country.
Victor now is at the country whose number is
1 , he wants to know the minimal amount of fuel for him to visit every country at least once and finally return to the first country.
Input
The first line of the input contains an integer
T , denoting the number of test cases.
In every test case, there are two integers
n and
m in the first line, denoting the number of the countries and the number of the flights.
Then there are
m lines, each line contains three integers
ui ,
vi and
wi , describing a flight.
1≤T≤20 .
1≤n≤16 .
1≤m≤100000 .
1≤wi≤100 .
1≤ui,vi≤n .
Output
Your program should print
T lines : the
i -th of these should contain a single integer, denoting the minimal amount of fuel for Victor to finish the travel.
Sample Input
Sample Output
Source
BestCoder Round #52 (div.2)
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int map[20][20];
int dp[1<<17][20];
int main(){
int t,n,m,w,u,v;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
memset(map,0x3f,sizeof(map));
for(int i = 0;i < n; i++)
map[i][i] = 0;
for(int i = 0;i < m; i++){
scanf("%d%d%d",&u,&v,&w);
u--,v--;
map[u][v] = map[v][u] = min(map[u][v],w);
}
for(int i = 0;i < n;i++)
for(int j = 0;j < n; j++)
for(int k = 0;k < n; k++)
map[j][k] = map[k][j] = min(map[j][k],map[j][i]+map[i][k]);
memset(dp,0x3f,sizeof(dp));
dp[1][0] = 0;
for(int i = 1;i < (1<<n);i++){
for(int j = 0;j < n; j++){
if(i&(1<<j)){
for(int k = 0;k < n; k++){
if((i&(1<<k))==0 && j != k){
dp[i|(1<<k)][k] = min(dp[i|(1<<k)][k],dp[i][j]+map[j][k]);
}
}
}
}
}
int ans = dp[0][0];
for(int i = 0;i < n; i++){
ans = min(ans,dp[(1<<n)-1][i]+map[i][0]);
}
printf("%d\n",ans);
}
return 0;
}
/*
33
4
10
1 2 1
1 3 1
1 4 10
2 3 1
2 4 10
3 4 1
1 3 10
1 4 10
1 2 10
1 3 10
3 2
1 2 2
1 3 3
*/