C语言二分图匹配(1)___Girls and Boys(Hdu 1068)

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set. 

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1, for n subjects. 
For each given data set, the program should write to standard output a line containing the result. 
 

Sample Input

      
      
      
      
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

Sample Output

      
      
      
      
5 2



题意:有n个人,下面n排分别表示第i个人分别和后面人有缘分,现在要找出最多的人使得这些人中互相没有缘分.


分析:最大独立集问题          

                       公式:               二分图最大独立集合 = 节点数 - 最大匹配数

注意:这道题因为是无向的,拆点之后,其最大匹配数实际上为真实的两倍,所以这里是  二分图最大独立集合 = 节点数 - 最大匹配数/2;


#include <cstdio>
#include <cstring>
#include <vector>
#include <iostream>
#include <queue>
#include <stdlib.h>
using namespace std;
int pre[505],visit[505];
vector<int>way[505];
int dfs(int step){
	int i,next;
	for(i=0;i<way[step].size();i++){
		next=way[step][i];
		if(visit[next])continue;
		visit[next]=1;
		if(pre[next]==-1 || dfs(pre[next])){
			pre[next]=step;
			return 1;
		}
	}
	return 0;
}
int main()
{
	int i,j,n,v,m,u,ans;
	while(cin>>n){
		for(i=0;i<505;i++)way[i].clear();
		for(i=0;i<n;i++){
			scanf("%d: (%d)",&v,&m);
			for(j=0;j<m;j++){
				cin>>u;
				way[v].push_back(u);
			}
		}
		memset(pre,-1,sizeof(pre));
		ans=0;
		for(i=0;i<n;i++){
			memset(visit,0,sizeof(visit));
			if(dfs(i)==1)ans++;
		}
		cout<<n-ans/2<<endl;
	} 
	return 0;
}


你可能感兴趣的:(C语言二分图匹配(1)___Girls and Boys(Hdu 1068))