HDU - 1251 - 统计难题(字典树)

HDU 1251.统计难题(字典树)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0

慢慢写Trie树的问题顺手多了,还是得多练,多刷题!



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;

typedef struct node{
    int cnt;
    struct node* next[26];
}Trie;

char s[15];
Trie* root;

void insert(){
    char *p = s;
    Trie* q = root;
    while(*p){
        if(q->next[*p-'a'] == 0){
            q->next[*p-'a'] = (node*)malloc(sizeof(node));
            memset(q->next[*p-'a'], 0, sizeof(node));
            q = q->next[*p-'a'];
            q->cnt++;
            p++;
        }
        else{
            q = q->next[*p-'a'];
            q->cnt++;
            p++;
        }
    }
}

void print_num(){
    char *p = s;
    Trie* q = root;
    while(*p && q->next[*p-'a'] != 0){
        q = q->next[*p-'a'];
        p++;
    }
    if(!*p)
        printf("%d\n", q->cnt);
    else
        printf("0\n");
}

int main()
{
    root = (Trie*)malloc(sizeof(node));
    memset(root, 0, sizeof(node));
    while(gets(s)){
        if (!strlen(s))   break;
        else{
            insert();
        }
    }
    while(gets(s)){
        print_num();
    }
    return 0;
}

你可能感兴趣的:(杭电,Trie树,字典树)