杭电 OJ1005Number Sequence(循环节)



Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 137754    Accepted Submission(s): 33375


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
   
   
   
   
1 1 3 1 2 10 0 0 0
 

Sample Output
   
   
   
   
2 5
 

Author
CHEN, Shunbao
#include<stdio.h>
#include<string.h>
int f[1000000];
using namespace std;
int main()
{
    int a,b,n;
    while(~scanf("%d%d%d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0)break;
        f[1]=1;
        f[2]=1;
        int i;
        for(i=3; i<=1000; i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            if(f[i]==1&&f[i-1]==1)
                break;
        }
        n=n%(i-2);
        f[0]=f[i-2];
        printf("%d\n",f[n]);
    }
}


你可能感兴趣的:(杭电,1005,循环节)