杭电 2710 Max Factor(快速打印素数表过)

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5339    Accepted Submission(s): 1744


Problem Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
 

Input
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line
 

Output
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
 

Sample Input
   
   
   
   
4 36 38 40 42
 

Sample Output
   
   
   
   
38
 
暴力也能过,这里给自己留一份网上快速打印素数表的模板:
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
#define max 20006
int Is_or[max];
int main()
{
    memset(Is_or,0,sizeof(Is_or));
    for(int j=2;j<sqrt(max);j++)//
    {
        if(Is_or[j]==0)//去掉合数的倍数.
        for(int k=j+j;k<=max;k+=j)//去掉倍数.(把这么些个合数的倍数都标记上这个数不是素数.)
        Is_or[k]=1;
    }
    int n;
    while(~scanf("%d",&n))
    {
        int temp=-0x1f1f1f1f;
        int output;
        for(int i=0;i<n;i++)
        {
            //printf("%d\n",Is_or[1]);
            int k;
            scanf("%d",&k);
            for(int j=k;j>=1;j--)
            {
                if(Is_or[j]==0&&k%j==0)
                {
                    if(j>temp)
                    {
                        temp=j;
                        output=k;
                        //printf("%d %d\n",j,output);
                        break;
                    }
                }
            }
        }
        printf("%d\n",output);
    }
}











你可能感兴趣的:(杭电2710)