hdu1159

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10900    Accepted Submission(s): 4464


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
   
   
   
   
abcfbc abfcab programming contest abcd mnp
 

Sample Output
   
   
   
   
4 2 0
 

Source
Southeastern Europe 2003
 
这个是一个求最长公共子序列的一个问题。。:
代码如下:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char str1[1000];
char str2[1000];
int map[1000][1000];
void cal()
{
    int m=strlen(str1+1);
    int n=strlen(str2+1);
    for(int i=0;i<=m;i++)
    {
        map[i][0]=0;
    }
    for(int i=0;i<=n;i++)
    {
        map[0][i]=0;
    }
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(str1[i]==str2[j])
            {
                map[i][j]=map[i-1][j-1]+1;
            }
            else
            {
                map[i][j]=max(map[i-1][j],map[i][j-1]);
            }
        }
    }
    cout<<map[m][n]<<endl;
}
int main()
{
    while(scanf("%s%s",str1+1,str2+1)==2)
    {
        cal();
    }
    return 0;
}


你可能感兴趣的:(hdu1159)