hdu 1712 ACboy needs your help(我的第一个分组背包:每组至多一个)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 761    Accepted Submission(s): 374

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

 

Sample Input
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0

 

Sample Output
  
3 4 6

           此题属于典型的分组背包,(每组至多一个背包)!!!
       看了背包9讲,直接用他上面所写的套上去就行了,三重循环记住每一重的意义。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;

int a[105][105];
int bag[105];
int N, V;

void _gro_bag()     //分组背包
{
    int i, j, k;
    memset(bag, 0, sizeof(bag));
    for(i = 1; i <= N; i++) //第一重循环是:分组数
    {
        for(j = V; j >= 0; j--) //第二重循环是:容量体积
        {
            for(k = 1; k <= V; k++) //第三重循环是:属于i组的k
            {
                if(j >= k)
                    bag[j] = max(bag[j], bag[j-k] + a[i][k]);
            }
        }
    }
}

int main()
{
    int i, j;
    while(scanf("%d%d", &N, &V), N+V)
    {
        for(i = 1; i <= N; i++)
            for(j = 1; j <= V; j++)
                scanf("%d", &a[i][j]);
        _gro_bag();
        printf("%d\n", bag[V]);
    }

    return 0;
}
 

你可能感兴趣的:(数据结构,算法,dp,ACM,背包)