问题描述
There are n numbers in a array, as a 0, a 1 … , a n-1, and another number m. We define a function f(i, j) = a i|a i+1|a i+2| … | a j . Where “|” is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
输入
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2 30) Then n numbers come in the second line which is the array a, where 1 <= a i <= 2 30.
输出
For every case, you should output “Case #t: ” at first, without quotes. The t is the case number starting from 1.
Then follows the answer.
样例输入
2
3 6
1 3 5
2 4
5 4
样例输出
Case #1: 4
Case #2: 0
看到位运算我就懵比了,每次看到位运算的第一感觉就是怎么把十进制转换成2进制,想了半天想不出来,在网上找的代码
#include<iostream>
#include<stack>
#include<queue>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<cmath>
#define ll long long
#define oo 1000000007
#define eps 1e-5
#define MAXN 100010
using namespace std;
int s[100005][32];
ll ans;
bool judge(int r,int l,int p)
{
int i;
if (l<0) l=0;
ll k=1,ans=0;
for (i=1;i<=30;i++)
{
if (s[r][i]-s[l][i]) ans+=k;
k*=2;
}
if (ans<p) return true;
return false;
}
int main()
{
int C,cases,i,n,x,k,p;
scanf("%d",&C);
for (cases=1;cases<=C;cases++)
{
scanf("%d%d",&n,&p);
memset(s,0,sizeof(s));
for (i=1;i<=n;i++)
{
memcpy(s[i],s[i-1],sizeof(s[i]));
scanf("%d",&x),k=0;
while (x)
{
k++;
s[i][k]=s[i-1][k]+x%2;
x>>=1;
}
}
ans=0;
for (i=1;i<=n;i++)
{
int l=i-1,r=n+1,mid;
while (r-l>1)
{
mid=r+l>>1;
if (judge(mid,i-1,p)) l=mid;
else r=mid;
}
ans+=l-i+1;
}
printf("Case #%d: %I64d\n",cases,ans);
}
return 0;
}
表示这个代码看了半天看不懂有木有,问了学长才发现解法原来很简单
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int a[100005];
int main()
{
int t;
cin>>t;
int T=t;
while(t--)
{
int n, m, con=0;
cin>>n>>m;
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int i=0; i<n; i++)
{
int res = a[i];
for(int j=i; j<n; j++)
{
res = res|a[j];
if(res<m) con++;
else
break;
}
}
printf("Case #%d: %d\n",T-t,con);
}
return 0;
}