HDU2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16831    Accepted Submission(s): 7123

题目大意:有一块高(h)X 宽(w)板子,上面要贴广告,广告条的高度均为1,长为给定的按先后顺序的数,询问广告贴在哪个位置,


思路:线段树;

 

Problem Description
At the entrance to the university, there is a huge rectangular (矩形的) billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<iostream>
#define LL long long
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define o (l+r)>>1
using namespace std;
const int N=220005;
int sum[N<<3];
int m;
void pushup(int rt)
{
    sum[rt]=max(sum[rt<<1],sum[rt<<1|1]);
}
void build(int l,int r,int rt)
{

    if(l==r)
    {
        sum[rt]=m;
        return ;
    }
    int mid=o;
    build(lson);
    build(rson);
    pushup(rt);
}
int Query(int x,int l,int r,int rt)
{
    if(l==r)
    {
            sum[rt]-=x;
            return l;
    }
    int mid=o;
    int ans= (x<=sum[rt<<1])?Query(x,lson):Query(x,rson);
    pushup(rt);
    return ans;
}
int main()
{
    int n,t,x;
    while(~scanf("%d%d%d",&n,&m,&t))
    {
        if(n>t)
            n=t;
        build(1,n,1);
        while(t--)
        {
           scanf("%d",&x);
           if(sum[1]<x)
            printf("-1\n");
           else
           printf("%d\n",Query(x,1,n,1));
        }
    }
    return 0;
}


 

你可能感兴趣的:(HDU2795 Billboard)