1009. Product of Polynomials

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
//这道题请注意count的计算。出现的问题,我在代码中写出来了!
#include<stdio.h>
#include<string.h>
using namespace std;

double a[1002];
double b[1002];
double res[2004];


int main()
{
	int n, i, temp;
	memset(a, 0, sizeof(a));
	memset(b, 0, sizeof(b));
	memset(res, 0, sizeof(res));
	scanf("%d",&n);
	
	for(i = 0; i < n; i ++)
	{
		scanf("%d", &temp);
		scanf("%lf", &a[temp]);
	}
	scanf("%d", &n);
	for(i = 0; i < n; i ++)
	{
		scanf("%d", &temp);
		scanf("%lf", &b[temp]);
	}
	
	int count = 0, p;

	for(i = 0; i < 1002; i ++)
	{
		for(int j = 0; j < 1002; j ++)
		{
			res[i+j] = res[i+j] + a[i] * b[j];
			/* 此时我在这里边计算count的个数就会不对。 
			if(res[i+j] != 0)
			count ++;
			*/
		}
	}
	
	//而在外边进行计算的发现,得到了想要的结果,不知道是因为什么原因 
	for(i = 2004; i >= 0; i --)
		if(res[i] != 0)
			count ++;
			
	printf("%d", count);
	

	for(i = 2004; i >= 0; i --)
		if(res[i] != 0)
		{
			count --;
			printf(" %d %.1f" , i, res[i]);
		}
		printf("\n");
	return 0;
}


你可能感兴趣的:(1009. Product of Polynomials)