POJ 3252 Round Numbers

数位DP,需要处理前导0.。。。。

Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8682   Accepted: 3046

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source

USACO 2006 November Silver

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
#define ERR puts("=======here========");
#define prt(k) cout<<#k"="<<k<<" "
#include<algorithm>

int dp[44][44][44][35];
int bit[66];
int dfs(int pos,int zero,int one,bool limit,int head   )
{
    if(pos==-1) return zero>=one;
    if(!limit&&~dp[pos][zero][one][head]) return dp[pos][zero][one][head];
    int end=limit?bit[pos]:1;
    int ret=0;
    for(int i=0;i<=end;i++)
    {
        if(i==0&&head==33) ret+=dfs(pos-1,zero,one,limit&&i==end,33);
        else  ret+=dfs(pos-1,zero+(i==0),one+(i==1),limit&&i==end,i);
    }
    if(!limit) dp[pos][zero][one][head]=ret;
    return ret;
}
int get(int n)
{
    int len=0;   //if(n<=0) return 0;
    while(n)
    {
        bit[len++]=n%2;
        n/=2;
    }
   // memset(dp,-1,sizeof dp);
    return dfs(len-1,0,0,1,33);
}
int main()
{
    memset(dp,-1,sizeof dp);
    int a,b;
    cin>>a>>b;
    {
        cout<<get(b)-get(a-1)<<endl;
    }
}


你可能感兴趣的:(POJ 3252 Round Numbers)