题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34251 Accepted Submission(s): 14101
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
题解:01背包
AC代码:
#include<iostream>
#include<cstring>
#define N 10005
using namespace std;
struct{
int v,c;
}Bag[N];
int n,v,f[N],t;
int main()
{
cin.sync_with_stdio(false);
cin>>t;
while(t--){
cin>>n>>v;
for(int i=1;i<=n;i++)
cin>>Bag[i].c;
for(int i=1;i<=n;i++)
cin>>Bag[i].v;
memset(f,0,sizeof(f));
for(int i=1;i<=n;i++)
for(int j=v;j>=Bag[i].v;j--)
f[j]=max(f[j],f[j-Bag[i].v]+Bag[i].c);
cout<<f[v]<<endl;
}
return 0;
}