Sicily 1007. To and Fro

Problem

Time Limit: 1sec
Memory Limit: 32MB

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x. Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x’ to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

Idea

The problem requires us to transform a linear string of lower cases into a matrix which stores characters alternating left-to-right and right-to-left. And then, we must print the characters column by column.

Solution

Considering that we must print the characters column by column, it’s natural to use two-dimension array.

#include<stdio.h>
#include<string.h>

int main(void) {
    int column, row, i, j;
    char encrypted[200], retangle[200][200];
    for (scanf("%d", &column); column > 0; scanf("%d", &column)) {
        scanf("%s", encrypted);
        row = strlen(encrypted) / column;
        int k = 0;
        for (i = 0; i < row; i++) {
            for (j = 0; j < column; j++) {
                // row 0,2,4... store charcters by way of left-to-right.
                // row 1,3,5... store charcters by way of right-to-left.
                retangle[i][(i % 2 == 0) ? j : (column - 1 - j)]
                = encrypted[k++];
            }
        }
        for (j = 0; j < column; j++) {
            for (i = 0; i < row; i++) {
                printf("%c", retangle[i][j]);
            }
        }
        printf("\n");
    }
    return 0;
}

However, if we imagine the matrix as a line, and find the mathmatical relation, we can only use one-dimension array.

#include<stdio.h>
#include<string.h>

int main(void) {
    int column, row, i, j;
    char encrypted[200];
    for (scanf("%d", &column); column > 0; scanf("%d", &column)) {
        scanf("%s", encrypted);
        row = strlen(encrypted) / column;
        for (j = 0; j < column; j++) {
            for (i = 0; i < row; i++) {
                printf("%c",
                encrypted[i * column + ((i % 2 == 0) ? j : (column - 1 - j))]);
            }
        }
        printf("\n");
    }
    return 0;
}

你可能感兴趣的:(sicily)