hdu 4223 Dynamic Programming?

Description

Dynamic Programming, short for DP, is the favorite of iSea. It is a method for solving complex problems by breaking them down into simpler sub-problems. It is applicable to problems exhibiting the properties of overlapping sub-problems which are only slightly smaller and optimal substructure.
Ok, here is the problem. Given an array with N integers, find a continuous subsequence whose sum’s absolute value is the smallest. Very typical DP problem, right?
 

Input

The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then a line with N integers Ai follows.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 1 000
3. -100 000 <= Ai <= 100 000
 

Output

For each test case, output the case number first, then the smallest absolute value of sum.
 

Sample Input

     
     
     
     
2 2 1 -1 4 1 2 1 -2
 

Sample Output

     
     
     
     
Case 1: 0 Case 2: 1
题目大意:求连续子序列的最小绝对值和。

解题思路:一道DP题目,但我用的是纯暴力,因为数据量比较小所以可以AC。

注意:min初始化赋值时,若是赋予num[1]的值,要注意赋予num[1]的绝对值,不然会WA。

#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;

#define N 1005

int num[N];

int main()
{
	int n;
	int t;
	int min;
	cin >> n;
    
	for (t = 1; t <= n; t++)
	{
		// Init.
		memset(num, 0, sizeof(num));
		int l;
		int m;
		cin >> m;
        
		// Read.
		for (int i = 1; i <= m; i++)
			cin >> num[i];
        
		min = abs(num[1]);
		// Count.
		for (int i = 1; i <= m; i++)
		{
			int sum = 0;
			for (int j = i; j <= m; j++)
			{
					sum += num[j];
					if (abs(sum) < min)
						min = abs(sum);
			}
		}
        
		cout << "Case " << t << ": " << min << endl;
	}
	return 0;}

你可能感兴趣的:(hdu 4223 Dynamic Programming?)