hdu1171 完全背包 两种解法 多重背包

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21202    Accepted Submission(s): 7460


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
   
   
   
   
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
   
   
   
   
20 10 40 40
 
很明显完全背包 容量为总的一半
数组要开大不然运行错误
 
  
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[500005],w[1005],num[1005];
int main()
{
	int n,m;
	while(cin>>n&&n>=0)
	{
		memset(dp,0,sizeof(dp));
		int i,j,v_sum=0,k;
		for(i=1;i<=n;++i)
		{
			cin>>w[i]>>num[i];
			v_sum+=w[i]*num[i];
		}
		m=v_sum/2;
		for(i=1;i<=n;++i)
		{
			for(k=1;k<=num[i];++k)
			{
				for(j=m;j>=w[i];--j)
				{
				
					dp[j]=max(dp[j-w[i]]+w[i],dp[j]); 
				}	
			}
		}
		cout<<v_sum-dp[m]<<" "<<dp[m]<<endl;		
	}
}


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[500005],w[1005];
int main()
{
	int n,m;
	while(cin>>n&&n>=0)
	{
		memset(dp,0,sizeof(dp));
		int i,j,a,v_sum=0;
		for(i=1;i<=n;++i)
		{
			cin>>w[i]>>a;
			v_sum+=w[i]*a;
		}
		m=v_sum/2;
		for(i=1;i<=n;++i)
		{
			for(j=w[i];j<=m;++j)
			{
				dp[j]=max(dp[j-w[i]]+w[i],dp[j]); 
			}		
		}
		cout<<v_sum-dp[m]<<" "<<dp[m]<<endl;		
	}
}

多重背包解法
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 350000
int dp[N],w[1000],v[1000];
int main()
{
	int n;
	while(cin>>n&&n>=0)
	{
		int i,j,k;
		memset(dp,0,sizeof(dp));
		int weight,value,number;
		int count=1,sum=0;;
		for(i=1;i<=n;++i)          
		{
			cin>>weight>>number;
			value=weight;
			sum+=weight*number;
			for(k=1;k<=number;k<<=1)
			{
				v[count]=k*value;
				w[count++]=k*weight;
				number-=k;
			}
			if(number>0)
			{
				v[count]=number*value;
				w[count++]=number*weight;
			}
		}
		for(i=1;i<=count-1;++i)
			for(j=sum/2;j>=w[i];--j)
				dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        cout<<sum-dp[sum/2]<<" "<<dp[sum/2]<<endl;
	}
	return 0;
}

完全背包几乎不耗时 但好空间  对比如下: 上边是完全背包解法

10487635 2014-04-06 20:18:04 Accepted 1171 0MS 2252K 643 B C++ 的鱼
10487606 2014-04-06 20:13:55 Accepted 1171 46MS 1668K 840 B C++ 向往蓝天的鱼


0
0

你可能感兴趣的:(hdu1171 完全背包 两种解法 多重背包)