hdoj Break the Chocolate 4112 (数学规律题)

Break the Chocolate

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4656    Accepted Submission(s): 1500


Problem Description
hdoj Break the Chocolate 4112 (数学规律题)_第1张图片
Benjamin is going to host a party for his big promotion coming up.
Every party needs candies, chocolates and beer, and of course Benjamin has prepared some of those. But as everyone likes to party, many more people showed up than he expected. The good news is that candies are enough. And for the beer, he only needs to buy some extra cups. The only problem is the chocolate.
As Benjamin is only a 'small court officer' with poor salary even after his promotion, he can not afford to buy extra chocolate. So he decides to break the chocolate cubes into smaller pieces so that everyone can have some.
He have two methods to break the chocolate. He can pick one piece of chocolate and break it into two pieces with bare hand, or put some pieces of chocolate together on the table and cut them with a knife at one time. You can assume that the knife is long enough to cut as many pieces of chocolate as he want.
The party is coming really soon and breaking the chocolate is not an easy job. He wants to know what is the minimum number of steps to break the chocolate into unit-size pieces (cubes of size 1 × 1 × 1). He is not sure whether he can find a knife or not, so he wants to know the answer for both situations.

Input
The first line contains an integer T(1<= T <=10000), indicating the number of test cases.
Each test case contains one line with three integers N,M,K(1 <=N,M,K <=2000), meaning the chocolate is a cube of size N ×M × K.

Output
For each test case in the input, print one line: "Case #X: A B", where X is the test case number (starting with 1) , A and B are the minimum numbers of steps to break the chocolate into N × M × K unit-size pieces with bare hands and knife respectively.

Sample Input
   
   
   
   
2 1 1 3 2 2 2

Sample Output
   
   
   
   
Case #1: 2 2 Case #2: 7 3
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#define ll __int64
int main()
{
	int t,T=1;
	ll n,m,l;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d%I64d%I64d",&n,&m,&l);
		ll ans=n*m*l-1;
		ll mm=ceil(log2(n)/log2(2))+ceil(log(m)/log(2))+ceil(log(l)/log(2));
		printf("Case #%d: %I64d %I64d\n",T++,ans,mm);
	}
	return 0;
} 

你可能感兴趣的:(hdoj Break the Chocolate 4112 (数学规律题))