Poj 3067 Japan

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15709   Accepted: 4221

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

Southeastern Europe 2006
跟随baoge的步伐,学学树状数组,本题算是算后n项和,倒一下就行,注意的是数据范围。。。。。。
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#define MAX 1050
using namespace std;
__int64 c[MAX];
int n,m,k;
struct node
{
    int x,y;
} point[1000005];

int lowbit(int i)
{
    return i & (-i);
}

int Sum(int i)
{
    int sum = 0;
    while(i <= 1001)
    {
        sum += c[i];
        i += lowbit(i);
    }
    return sum;
}

void add(int i)
{
    while(i > 0)
    {
        c[i] ++;
        i -= lowbit(i);
    }
}

bool cmp(node a, node b)
{
    if(a.x == b.x)
        return a.y < b.y;
    return a.x <b.x;
}

int main()
{
    int t,d=1;
    scanf("%d",&t);
    while(t--)
    {
        __int64 sum = 0;
        scanf("%d%d%d",&n,&m,&k);
        memset(c,0,sizeof(c));
        for(int i=0; i<k; i++)
        {
            scanf("%d%d",&point[i].x,&point[i].y);
        }
        sort(point,point+k,cmp);
        for(int i=0; i<k; i++)
        {
            sum += Sum(point[i].y+1);//必须加1,后n项和不包括本身
            //cout << sum << endl;
            add(point[i].y);
        }
        printf("Test case %d: %I64d\n",d++,sum);
    }
    return 0;
}

你可能感兴趣的:(Poj 3067 Japan)