HDU1181:变形课(DFS)

Description

呃......变形课上Harry碰到了一点小麻烦,因为他并不像Hermione那样能够记住所有的咒语而随意的将一个棒球变成刺猬什么的,但是他发现了变形咒语的一个统一规律:如果咒语是以a开头b结尾的一个单词,那么它的作用就恰好是使A物体变成B物体. 
Harry已经将他所会的所有咒语都列成了一个表,他想让你帮忙计算一下他是否能完成老师的作业,将一个B(ball)变成一个M(Mouse),你知道,如果他自己不能完成的话,他就只好向Hermione请教,并且被迫听一大堆好好学习的道理. 
 

Input

测试数据有多组。每组有多行,每行一个单词,仅包括小写字母,是Harry所会的所有咒语.数字0表示一组输入结束. 
 

Output

如果Harry可以完成他的作业,就输出"Yes.",否则就输出"No."(不要忽略了句号) 
 

Sample Input

     
     
     
     
so soon river goes them got moon begin big 0
 

Sample Output

     
     
     
     
Yes.

Hint

Hint  Harry 可以念这个咒语:"big-got-them".
        
        
 代码:利用队列可解
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
const int Max=1500;
struct node
{
    char top;
    char rear;
}a[Max];
int used[Max];
int main()
{
    char ch[Max];
    node b;
    queue<struct node>q;
    while(cin>>ch)
    {
        memset(used,0,sizeof(used));
        int len,i=0;
        if(ch[0]!=0)
        {
            a[i].top=ch[0];
            len=strlen(ch);
            a[i].rear=ch[len-1];
            i++;
        }
        while(cin>>ch)
        {
            if(ch[0]!='0')
            {
                len=strlen(ch);
                a[i].top=ch[0];
                a[i].rear=ch[len-1];
                i++;
            }
            else
                break;
        }
        for(int j=0;j<i;j++)
        {
            if(a[j].top=='b')
            {
                used[j]=1;
                q.push(a[j]);//jinzhan
            }
        }
        while(!q.empty())
        {
            b=q.front();
            q.pop();
            if(b.rear=='m')
            {
                cout<<"Yes."<<endl;
                break;
            }
            else
            {
                for(int j=0;j<i;j++)
                {
                    if(a[j].top==b.rear&&!used[j])
                    {
                        used[j]=1;
                        q.push(a[j]);
                    }
                }
            }
        }
        if(b.rear!='m')
        {
            cout<<"No."<<endl;
        }
    }
}

你可能感兴趣的:(HDU1181:变形课(DFS))